http://userscripts.org/scripts/show/114002


이제까지 사용해본 youtube 사용자 스크립트 중에서 단연 최고다.


아래는 내가 설정한 옵션



설정버튼은 로그인 옆에


한글화가 되면 좋겠다



기본 해상도는 720으로 하면 조금 버퍼링이 있는데 

Dash Playbak을 하면 버퍼링이 없이 쾌적하다


embed된 유툽 영상에도 옵션을 줄 수 있다.




기본 크기 변경 버튼의 옵션중 Large




영상의 하단의 기능 버튼충 Light는 아래와 같이 영상감상에 좋게 만들어준다.




하루종일 인터넷 서치를 해봤지만 예제 수준 이상의 코드는 보이지 않았다.


넘겨 받을 데이터는 Array 타입의 JSON 이였는데  예제들의 설명이 충분하지 않아서 삽질을 조금 했다.


CString m_JSonResult 에 담겨 있는 Array 데이터를 파싱해서 iterateor로 값을 참조 하는 예제 코드이다.


속도는 rapidjson이 두배 정도 빠르다. 다른 라이브러리도 한두개 더 테스트를 해봐야겠다.




void CJsonTest::rapidjson()
{
    rapidjson::Document jsondoc;
 
    if (jsondoc.ParseInsitu<0>((LPSTR)(LPCTSTR)m_JSonResult).HasParseError() == false){
        rapidjson::Document::ValueIterator iter = jsondoc.Begin();
        for(; iter != jsondoc.End(); iter++){
            rapidjson::Value& oneItem = *iter;
            CString szTitle = oneItem[_T("TestTitle1")].GetString();
            TRACE(_T("%s\n"),szTitle);

            szTitle = oneItem[_T("TestTitle2")].GetString();
            TRACE(_T("%s\n"),UTF8ToA(szTitle));
        }
    }else{
        TRACE(_T("%s\n"),jsondoc.GetParseError());
    }
}

void CJsonTest::jsoncpp()
{
    Json::Value root;
    Json::Reader jsondoc;
    if(jsondoc.parse((LPSTR)(LPCTSTR)m_JSonResult,root)){
        Json::Value::iterator iter = root.begin();

        for(;iter != root.end(); iter++){
            Json::Value oneItem = *iter;
            CString szTitle = oneItem.get(_T("TestTitle"),_T("TEST")).asCString();
            TRACE(_T("%s\n"),szTitle);

            szTitle = oneItem.get(_T("TestTitle2"),_T("TEST")).asCString();
            TRACE(_T("%s\n"),UTF8ToA(szTitle));
        }
    }else{
        TRACE(_T("error\n"));
    }
}

사내에서 사용하는  cyberoam 장비에 로그 기록을 위해서 syslog 서버를 설정하다보니 로그파일은 간단히 설정이 되는데  로그파일을 볼려니까 답답해서 검색해보니 iview라는것이 있다.


syslog 서버 설정은 원상 복구하고 아래의 방법대로 iview를 설치



여러 장비들을 지원한다.


http://www.cyberoam-iview.org/


http://sourceforge.net/projects/cyberoam-iview/


일단 설치 파일을 다운받자


http://sourceforge.net/projects/cyberoam-iview/files/iVew-Beta/


도움말 문서도 한번 일단 읽어보자


Cyberoam iView Linux Installation Guide.pdf



설치에 필요한 조건은 postgrsql 8.4 와 java 1.5 이상.


centos 5.9에는 8.1이 설치된다.


yum remove postgresql

yum install postgresql84-server


service postgresql start

초기화 하라고 나온다 하란대로 하고 다시 시작 시킨다.


iView 설치본에서 postgresql-8.4 를 찾는다. 만들어주자


cd /etc/init.d

cp postgresql postgresql-8.4


다운받은 iView***.bin 파일에 실행권한을 주고 실행 - pdf에 나와 있다.




캡쳐 화면에는 /var/iview 에 설치 하라고 나오는데 나는 다른 경로에 설치했다.

jvm 의 경로는 /usr/lib/jvm 에서 확인!


/usr/local/iview
/usr/local/iview/archive
/var/lib/pgsql
/usr/lib/jvm/jre-1.6.0-openjdk


정상적으로 완료가 되면 서비스를 구동하자

service iviewd restart


iview서버:8000 으로 접속하면 로그인 페이지가 나온다.


이것 저것 눌러보다보면 장비가 검색되었다고 나온다. 혹시 안나오면 system 설정에서 장비 지정을 하면 될 것같다.


10분쯤 지나니까 로그데이터가 올라온다. 좀더 상세한 리포트 인데 내가 찾아보기에는 충분히 상세하다.

redmine 2.3.1로 업그레이드 진행 (rev 11759)



svn up -r11759

bundle install --without development test postgresql sqlite


bundle update를 진행하라는 메시지


그러나 bundle update를 하면 postgresql 버전이 낮아서 pg를 설치 할 수 없다는 메시지


나는 postgresql 안쓰는데..ㅡ.ㅡ;;;


Gemfile을 열어보니


# Include database gems for the adapters found in the database
# configuration file
require 'erb'
require 'yaml'
database_file = File.join(File.dirname(__FILE__), "config/database.yml")
if File.exist?(database_file)
  database_config = YAML::load(ERB.new(IO.read(database_file)).result)
  adapters = database_config.values.map {|c| c['adapter']}.compact.uniq
  if adapters.any?
    adapters.each do |adapter|
      case adapter
      when 'mysql2'
        gem "mysql2", "~> 0.3.11", :platforms => [:mri, :mingw]
        gem "activerecord-jdbcmysql-adapter", :platforms => :jruby
      when 'mysql'
        gem "mysql", "~> 2.8.1", :platforms => [:mri, :mingw]
        gem "activerecord-jdbcmysql-adapter", :platforms => :jruby
      when /postgresql/
        gem "pg", ">= 0.11.0", :platforms => [:mri, :mingw]
        gem "activerecord-jdbcpostgresql-adapter", :platforms => :jruby
      when /sqlite3/
        gem "sqlite3", :platforms => [:mri, :mingw]
        gem "activerecord-jdbcsqlite3-adapter", :platforms => :jruby
      when /sqlserver/
        gem "tiny_tds", "~> 0.5.1", :platforms => [:mri, :mingw]
        gem "activerecord-sqlserver-adapter", :platforms => [:mri, :mingw]
      else
        warn("Unknown database adapter `#{adapter}` found in config/database.yml, use Gemfile.local to load your own database gems")
      end
    end
  else
    warn("No adapter found in config/database.yml, please configure it first")
  end
else
  warn("Please configure your config/database.yml first")
end


설마...저것 때문에???


database.yml 파일을 열어보니 test_pgsql 부분이 딱!!


주석처리하고 bundle update를 하니 잘 넘어간다.

Recognize It for Chrome


사용해본 제스처 확장중에서는 가장 마음에 든다.



사용하던 redmine의 버전이 1.2* 였는데 2.1.2 버전까지 버전이 올라서 업그레이드 하기로 결정!!

안해도 사용상 문제는 없었지만 너무 버전차이가 나면 나중에 업그레이드가 곤란해질 수도 있을 수도 있으니까.


*설치 조건 확인!


http://www.redmine.org/projects/redmine/wiki/RedmineInstall


 ruby 1.8.6 이 설치 되어 있었는데 1.8.7이 필요했다. CentOS 는 여전히 기본 1.8.5로만 배포중.. 게다가 1.8.6을 설치했던 저장소는 없어졌는지 에러 발생


 기존 설치본부터 삭제 하고 1.8.7을 설치할 방법을 찾아보니..컴파일을 하는것말고 rvm을 이용하는 방법이 있는데 이걸 해보려고 했으나 무엇이 문제인지 설치 불가..


1.8.7을 제공하는곳을 추가하고 설치


http://centos.karan.org/el5/ruby187/


cd /etc/yum.repos.d/

wget http://centos.karan.org/el5/ruby187/kbs-el5-ruby187.repo


yum install ruby


rubygem 은 1.3.7이 설치되어 있으나 업그레이드 하는김에 1.8.24로 업그레이드


wget http://rubyforge.org/frs/download.php/76073/rubygems-1.8.24.tgz
tar xvfz rubygems-1.8.24.tgz
cd rubygems-1.8.24
ruby setup.rb
gem -v


bundle 설치


gem install bundler


* 본격적인 업그레이드 시작

http://www.redmine.org/projects/redmine/wiki/RedmineUpgrade


현재 사용중인 버전도 svn에서 직접받은것이라서 redmine 설치 경로로 이동

svn update


필요한 의존성 설치 - MySQL 을 사용중이므로 다른 DB 는 제외

bundle install --without development test postgresql sqlite


ImageMagic 에 대한 문제 발생하여 기존 설치된것을 제거하고, 홈페이지에서 다운받아서 설치

wget http://www.imagemagick.org/download/linux/CentOS/i386/ImageMagick-6.8.0-3.i386.rpm
wget http://www.imagemagick.org/download/linux/CentOS/i386/ImageMagick-devel-6.8.0-3.i386.rpm

rpm -Uvh ImageMagick-6.8.0-3.i386.rpm
rpm -Uvh ImageMagick-devel-6.8.0-3.i386.rpm

http://www.imagemagick.org/script/binary-releases.php

위의 링크가 동작 하지 않으면 마지막 버전을 확인


다시 bundle install 실행하니 정상적으로 완료!

* 마이그레이션

rake db:migrate RAILS_ENV=production

사용하지 않는 rb파일에 대해서 에러문구대로 처리 하고 다시 실행시키니 마이그레이션 진행

* Clean Up
rake tmp:cache:clear
rake tmp:sessions:clear

service httpd restart


완료!!


관리자로 로그인해서 역활및 권한 부분에 추가되거나 변경된 사항이 있는지 확인하고 설정



출근후 부팅을 하고 평소대로 vmplayer를 실행시키니 새버전이 나왔다고 한다.


다운로드 받고 업그레이드를 하니


상업적인 사용은 정품을 사라고 뜬다.


다른걸 알아봐야하나...정품 구입해달라고 해야하나..


일단 다시 다운그레이드..





라이센스 사항을 살펴보는중인데 이런게 보인다.  VMWare Fusion이 있으면 사용이 가능할것같다.

다행이 라이센스가 있다. :)


http://www.vmware.com/products/player/faqs.html


What does it cost?
VMware Player is free for personal non-commercial use. VMware Player is available for commercial use as part of VMware Fusion Professional . VMware Fusion Professional provides a commercial license that can be used with VMware Fusion on the Mac or with VMware Player on Windows or Linux. VMware Support and Subscription offerings are available for VMware Fusion Professional.

Is Support and Subscription available for commercial use of VMware Player?
Yes, if you purchase a minimum of 10 license of VMware Fusion Professional. VMware Fusion Professional includes a commercial license for VMware Player.


이전버전에서는 설치 하면서 재부팅과정이 있었는데 5.0에서는 이부분이 개선되었다.

리눅스에서 아주 유용하게 쓰이는 심볼릭 링크의 기능을 윈도우7 에서도 사용할 수 있는데 편리하게 사용할 수 있는 GUI프로그램이다.


관리자 권한으로 명령창을 열고


mklink 를 사용해서 심볼링크를 만드는 방법도 있지만 간단히 사용할 수 있는 GUI 프로그램이 있다.


http://schinagl.priv.at/nt/hardlinkshellext/hardlinkshellext.html


OS에 맞는 버전을 다운로드 받고 설치하면 팝업메뉴가 추가되고


고른다음 떨구면 된다. 아주 편리하다.


그림으로 잘 설명되어 있어서 사용하기 편리하다.





파일 저장 위치를 항상 물어보게 해두고 사용을 하는데

전에는 마지막으로 다운받은 경로에 계속 받게 해주더니

얼마전 8로 업데이트 되고부터는

url에 따라서 저장위치를 기억하는것 같습니다.

어디에서 다운받느냐에 따라서 그 위치에 저장되게 해주는것같네요.

오호..이거 좋군요.
어제 업데이트를 했다. 탐색기에서 오버레이 아이콘이 안보인다.

이전처럼 버그구나..그러고 롤백했습니다.


다른데서 정보를 보니 1.7로 버전업하면서 내부 구조가 바뀌어서 아이콘이 안나온다는군요.


릴리즈 노트를 보면 업그레이드를 하라고 하는데. 꼬일 수가 있나봅니다. 정리 하고 하라는걸보면.

안전하게 현재 버전으로 모두 커밋하고 업그레이드를 해봐야겠습니다.



ps. 업그레이드 하니 잘되는군요.