yum 으로 설치된 subversion의 버전은 1.4 버전대라서 업그레이드 하려고 찾아보니

rpm으로 되어 있는걸 받아서 설치 해야 하는데 어딘가 가입해야 하고 그러는게 번거롭다고 생각되서 컴파일 해보기로 하고 찾아보니 간단하게 될것 같아서 해보니까 쉽네요.

컴파일 환경은 잡혀 있다고 생각하고

소스 받아서 압축 풀기
cd /usr/local/src/
wget http://subversion.tigris.org/downloads/subversion-1.6.15.tar.gz
wget http://subversion.tigris.org/downloads/subversion-deps-1.6.15.tar.gz
tar xvzf subversion-1.6.15.tar.gz
tar xvzf subversion-deps-1.6.15.tar.gz
cd subversion-1.6.15
컴파일
./configure --prefix=/usr/local/subversion --with-ssl
make && make install
/usr/local/subversion/ 에 설치가 되는데 이걸 PATH에 추가 합니다.

vim /etc/profile

중간에
# Path manipulation
if [ "$EUID" = "0" ]; then
        pathmunge /sbin
        pathmunge /usr/sbin
        pathmunge /usr/local/sbin
        pathmunge /usr/local/subversion/bin
fi
저장하고나서
source /etc/profile
svn --version
설치 버전이 확인되는군요.
svn, 버젼 1.6.15 (r1038135)
    Dec 31 2010, 01:00:54에 컴파일 됨
한참 자료 찾아다녔는데 해보니 간단하네요.


ps. 뭐가 잘못되었는지 웹서버 재시동시 에러가 나는군요.

Cannot load /usr/lib/httpd/modules/mod_dav_svn.so into server: /usr/local/subversion/lib/libsvn_subr-1.so.0: undefined symbol: apr_hash_clear
분명 모듈은 제대로 들어간것 같은데 구글링해봐도 문제점이 있다는건 보이는데  해결책은 딱히 안보입니다.
일단은 httpd.conf에서 해당 모듈부분을 주석처리하고 사용하고있지만
차후에 웹서버와 연동하려고 한다면 해결책을 찾아야 할텐데..그건...나중에..필요하면...차후에..ㅡ.ㅡ;;;

저작자 표시 비영리 변경 금지
신고
윈도우에 MRTG를 설치 해서 사용할때는 별 문제가 없었는데

CentOS 5.5 에 MRTG를 설치하고 사용하려고 해보니 한글이 깨져보이는 문제가 생겼다.

검색해보니 아파치의 AddDefaultCharset 이 범인!

off 하고 아파치를 재구동하니 한글이 깨끗하게 나온다.

/etc/httpd/conf/http.conf

AddDefaultCharset UTF-8  기본값으로 이렇게 되어 있는부분을
AddDefaultCharset off 로 설정한다.


저작자 표시 비영리 변경 금지
신고
VirtualBox 버전 업그레이드 할때마다 방법을 찾는다..ㅡ.ㅡ; 망할 기억력..

게스트 확장 경로로 이동

sh VBox***.run  으로 실행


저작자 표시 비영리 변경 금지
신고